visual-studio - para - highlight matching tag



Múltiple emulador de estudio visual para los errores de Android (2)

Debe reiniciar su computadora después de instalar el emulador para aplicar los cambios que le permiten trabajar con conmutadores virtuales. Si todo lo demás falla, elimine todos los conmutadores mediante el Administrador de dispositivos en Windows y vuelva a iniciar un emulador (lo que le permite recrear estos conmutadores).

No puedo ejecutar visual emulator studio para Android. Recibo este error al presionar el botón de reproducción verde en el perfil del dispositivo:

Encontramos un problema al iniciar este dispositivo. Intente de nuevo o vea el archivo de registro para más detalles.

Aquí está el registro:

26.08.2015 22:24:32: [Informational] Waiting to launch device...
26.08.2015 22:24:32: [Informational] Launching Device: 5" KitKat (4.4) XXHDPI Phone
26.08.2015 22:24:32: [Informational] Validating emulator arguments...
26.08.2015 22:24:32: [Informational] Determining if emulator is already running...
26.08.2015 22:24:32: [Informational] Preparing virtual machine...
26.08.2015 22:24:33: [Critical] An error occured while creating 'VS Emulator 5" KitKat (4.4) XXHDPI Phone' device.
26.08.2015 22:24:33: [Critical] XDE Path: C:\Program Files (x86)\Microsoft XDE\10.0.10240.0\xde.exe
26.08.2015 22:24:33: [Critical] XDE Arguments: /sku Android /displayName "VS Emulator 5\" KitKat (4.4) XXHDPI Phone" /memSize 2048 /diagonalSize 5 /video "1080x1920" /vhd "C:\Users\Александр\AppData\Local\Microsoft\VisualStudioEmulator\Android\Containers\Local\Devices\vhd\5_KitKat_(4.4)_XXHDPI_Phone\image.vhd" /name "VS Emulator 5-inch KitKat (4.4) XXHDPI Phone.александр" /noStart /silent
26.08.2015 22:24:33: [Critical] XDE Exit Code: InvalidArguments (3)

El emulador de Windows Phone funciona perfecto. Reparar y volver a instalar el emulador no ayudó. Comprobado, que soy miembro del grupo Administradores de Hyper-V.

UPD1: Pude ejecutar el emulador de todos modos. Lo lancé desde el símbolo del sistema sin 2 últimos parámetros: "/ noStart / silent". Luego vi un diálogo sobre la configuración de la conexión a Internet y presioné "NO". Y el emulador se lanzó con éxito. Tal vez el problema esté en algún lugar del administrador de Hyper-V -> switches virtuales? Tengo 10 conmutadores virtuales iguales allí, y no puedo eliminarlos: "Error al eliminar el conmutador Ethernet virtual".

UPD2: ahora, mi aplicación unity3d no funciona. Lo despliego arrastrando una gota, luego presiono su ícono y aparece una pantalla negra. ¿Es por un error de conexión a internet del emulador?


El tercer argumento está en el Nombre.

5 \ "

/sku Android /displayName "VS Emulator 5\" KitKat (4.4) XXHDPI Phone" 

Cambie el nombre en C: \ Users \ windowsuser \ AppData \ Local \ Microsoft \ VisualStudioEmulator \ Android \ Containers \ Local \ Devices \ xxxxx_Phone.cfg

device.name=MyDevice (4.4)




android-emulator